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This dataset contains:
· Overview of flume experiments and datasets (this document)
· Flume topography (Terrestrial laser scanner data; .pts) 
· CT scans (raw and processed; .tif, metadata, .mat)
Flume experiments overview
The aim of the flume experiments was to measure the grain-scale structure of a water-worked gravel bed, and to assess how this structure varied through a riffle-pool sequence. The flume experiments are presented in Voepel et al., (2019):
“A prototype scale riffle-pool sequence was constructed in a large (60 m long × 2.1 m wide ×  0.7 m deep) flume at the University of Southampton’s Chilworth Hydraulics facility, using river gravels with a grain size distribution that was carefully matched through sieving to those found in a natural riffle-pool system at Bury Green Brook, UK (mean D50 range is 25 mm to 34 mm; (Hodge et al., 2013)). Prior to water-working, a series of five 250 mm diameter metal mesh baskets were buried with the rim 1.5 × D50 below the surface of the bed, allowing the surface grains of the bed to move without being impeded. Water-working of the gravels was achieved by slowly raising the flow rate at the start of each flume run to a critical flow level (when several painted D50 stones placed on the riffle mobilised) where it was sustained for fifteen minutes prior to reducing the flow to a half critical level for six hours. Powell et al. (2016) show that the majority of bed adjustment occurs over this timescale. The mean ± standard deviation of half critical flow pooled over all flume runs was 6.26 × 10−2 ± 5.97 × 10−3 m3 s−1 with half critical flow for individual flume runs ranging from 5.44 × 10−2 ± 1.87 × 10−2 m3 s−1 to 7.03 × 10−2 ± 2.02 × 10−2 m3 s−1.”
16 runs were performed, with each set of conditions being repeated three times. The bulk sediment mixture was the same between all runs, and we added increasingly finer sediment to the flume as the experiment progressed (Table 1). The smallest grain size in the initial mixture was 4 mm. Bridging sands were 1.4 - 4 mm, fine sands were 0.063 – 1.4 mm, and clay  was 1 − 4 μm. Sands were added to the flume using a hopper across the surface of the flume. Clay was continuously added to the inlet flow to achieve a steady concentration of either 100 or 500 mg L−1 throughout the run, measured using a conductivity meter with a predetermined calibration. In all runs the final sediment was framework supported. 
	Run
	Discharge during waterworking  (m3 s-1)
	Date
	Additional sediment input type
	Median grain size (mm) of added sediment mass (kg)
	Data available

	
	
	
	
	2.5
	1.5
	0.75
	0.4
	0.2
	TLS & CT

	1
	0.024
	06/10/14
	None
	
	
	
	
	
	TLS & CT

	2
	0.056
	11/10/14
	None
	
	
	
	
	
	TLS & CT

	3
	0.054
	14/10/14
	None
	
	
	
	
	
	TLS & CT

	4
	0.066
	29/10/14
	Bridging sands
	175
	125
	
	
	
	TLS & CT

	5
	0.064
	04/11/14
	Bridging sands
	25
	25
	
	
	
	TLS & CT

	6
	0.068
	08/11/14
	Bridging sands
	25
	25
	
	
	
	TLS & CT

	7
	n/a
	11/11/14
	Fine sands
	
	
	150
	125
	125
	TLS & CT

	8
	0.066
	17/11/14
	Fine sands
	
	
	25
	25
	25
	TLS & CT

	9
	0.059
	23/11/14
	Fine sands
	25
	25
	25
	25
	25
	TLS & CT

	10
	0.068
	28/11/14
	Clay 1 (100 mg/L)
	
	
	
	
	
	TLS & CT

	11
	0.069
	02/12/14
	Clay 1 (100 mg/L)
	25
	25
	25
	25
	25
	TLS & CT

	12
	0.066
	07/12/14
	Clay 1 (100 mg/L)
	25
	25
	25
	25
	25
	TLS & CT

	13
	n/a
	22/12/14
	Clay 2 (500 mg/L)
	25
	25
	25
	25
	25
	TLS

	14
	0.067
	02/01/15
	Clay 2 (500 mg/L)
	25
	25
	25
	25
	25
	TLS

	15
	0.074
	05/01/15
	Clay 2 (500 mg/L)
	25
	25
	25
	25
	25
	TLS & CT


Table 1: Details of flume run conditions. CT: CT scans of baskets in 5 locations. TLS: TLS scan from before and after waterworking. n/a refers to runs where discharge measurements were not able to be made.
[image: ]Figure 1: Flume and example basket.

Terrestrial Laser Scan (TLS data)
TLS data was collected of the flume bed before and after water-working, under zero flow conditions, for Runs 1 through 15. Data for all runs were collected using a Leica C10 scanner, with the exception of run 6 where a Leica P20 scanner was used. 10 High Definition Survey Targets were fixed to the flume infrastructure for the duration of all experiments and these were surveyed into an arbitrary co-ordinate system using a Leica Total Station. Scanning was undertaken from the gantry spanning the flume, from three static locations for each pre- or post-run scan; upstream scanning downstream, midstream scanning both upstream and downstream and downstream scanning upstream. Resolution was set to High (0.02 x 0.02 m vertical and horizontal spacing at 100 m), meaning that all data within the experimental area were collected at considerably higher resolution. In addition most areas of the flume had at least two convergent (from up- and down-stream) scans covering them. Photos were taken on the scanner, meaning that the data also has RGB values for all but Run 6.
The separate scans for each run were registered to the target locations (arbitrary grid) using Leica Cyclone software, to a RMSE of 0.005 m or better. Registration errors for each set of scans are provided in the folder Registration_stats. Data was subsequently manually clipped to the flume extent and exported as text (PTS) files, which includes the following:
Row 1: Total number of points exported
Row 2 onwards: The data as - X, Y, Z, intensity, R, G, B 
The additional ‘flume_points.txt’ file contains the total station survey locations of the ADV 0,0 grid coordinate locations, water surface elevations and HDS target locations, and can be used to locate the baskets in the TLS datasets (same arbitrary grid).
CT data
In each of run 1 through 15, baskets were buried in riffle crest, pool head, pool shallow, pool deep and pool tail locations. Basket locations are shown in Figure 2. At the end of each run, the baskets were carefully extracted and briefly submerged in liquid wax to fix the in situ spatial arrangement of bed grains prior to transport to the scanner. From Voepel et al. (2019): “The baskets of sediment were imaged using a micro-focus Nikon Metrology μCT scanner at the μ-VIS X-Ray Imaging Centre, University of Southampton, UK. The image scanner has a 450 kVp X-ray source and a 2048 pixel Curved Linear Detector Array (CLDA). Data were acquired using an electron accelerating potential of 440 kVp and a tube current of 922 μA. 951 equiangular projections were acquired through 360° with 4 frames per projection taken to reduce noise. An exposure time of 60 ms was used. A detailed discussion of XCT artefacts and corrections is presented in Clausnitzer and Hopmans (2000). 3D reconstruction of the projections was performed using NITRO, a quasi-Newton and trust region differentiable optimisation algorithm found in Digi XCT (Digisens, 2014; More and Sorensen, 1983; Nocedal and Wright, 1999). The resulting isometric voxel (the 3D extension of a 2D pixel) size is 600 μm. Interactive volume registration was performed using VGStudio Max 2.1 (Graphics, 2011). Three reference points were used to rotate and align the 3D datasets orthogonal to the original directions of flow and gravity, which is an important stage for later calculations of grain geometry and exposure area in relation to downstream flow direction.” Further information is provided in the appendix to this document.

[image: ]
Figure 2: Flume set-up and basket locations.

CT data are included in two formats: pre- and post-processing:
Pre-processed data
Pre-processed CT data are provided for most baskets (Table 2). A small number of baskets are missing because of data storage errors. There data are provided in the ‘HUTCH_files’ folders, which contain the sonograms and metadata needed to reconstruct the projections, using the approach outlined above. In many cases multiple baskets were scanned at once, and so many HUTCH_files folders contain data from more than one basket. 

Post-processed data
Two forms of post-processed data are provided. Due to time constraints during the project, not all baskets were processed in all ways (Table 2).

The first form is CT image stacks, in .tiff format. For each run, these are found in the folders called (e.g.) ‘R1_1YY_Riffle’, where R1 corresponds to run 1, 1YY is a basket identifier, and Riffle is the basket location. Each folder contains up to three sub-folders; Processed, ParticlesFull, and Matrix. (Not all processing was performed on all baskets due to project time constraints.) The images in the Processed folder have been reconstructed from the files in the HUTCH folder, and include all components of the basket (i.e. grains, fine matrix, the basket). The accompanying .html files contain the reconstruction parameters (though this is missing for Run 3, basket 5). Images in the other two folders represent the outputs of the image de-noising, training and segmentation process. Images in the ParticlesFull are binary images that contain only the coarse grains in the basket, and images in the Matrix folder are greyscale images that contain only the fine-grained matrix. Images in the Processed folder are not necessarily aligned to the flow direction. Flow direction is indicated by a plastic marker on the basket rim, and is also shown in the basket photos. Images in the other folders are aligned to the flow direction. 

The second form of post-processed data is a Matlab .mat file. This contains a binary 3D array of the bed structure, and properties of all of the individual sediment grains. These data have been published in Hodge et al. (2020), and the code used to generate the file can be found at: https://github.com/NERCPATCheS/VectorEntrainment3D The contents of the .mat file are outlined in Table 3.

	Run no
	1 Riffle crest
(YY/GY/OY)
	2 Pool head
(RR/RG/GO)
	3 Pool deep
(RB/GG/BO)
	4 Pool shallow
(BB/GB/PO)
	5 Pool tail
(PY/GP/OO)

	1
	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset

	2
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset

	3
	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
ParticlesFull

	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
ParticlesFull
Matrix
Matlab dataset

	4
	X
	X
	X
	X
	X

	5
	X
	X
	X
	X
	x

	6
	Processed
ParticlesFull
	Processed
ParticlesFull
	Processed
ParticlesFull
	Processed
ParticlesFull
	Processed
ParticlesFull

	7
	X
	X
	x
	x
	X

	8
	Processed
ParticlesFull
	Processed
ParticlesFull 
	Processed
ParticlesFull
	Processed
ParticlesFull
	Processed
ParticlesFull

	9
	X
	X
	X
	X
	X

	10
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset

	11
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset
	X
	Processed
ParticlesFull
Matrix
Matlab dataset

	12
	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
ParticlesFull 
	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
ParticlesFull 
	Processed
ParticlesFull
Matrix
Matlab dataset

	13
	No data
	No data
	No data
	No data
	X

	14
	X 
	No data
	No data
	No data
	X

	15
	Processed
ParticlesFull 
	Processed
ParticlesFull 
	Processed
ParticlesFull 
	Processed
ParticlesFull
Matrix
Matlab dataset
	Processed
ParticlesFull 


Table 2: Details of processing performed and data available for each basket. X: raw CT data only available. No data: all data were lost due to data storage errors. RXXX_0final.tif: file name of segmented image stack. File names with ‘Ring’ in indicated that extra processing was performed to remove ring artefacts. Matlab dataset: Data from this basket are included in the Matlab dataset of grain properties. Letters in the header row refer to the colours of the tapes on the baskets, and can be used to identify baskets in the photos. There were three sets of baskets, hence baskets in any given location had one of three tape colour combinations. Colour codes are: R = Red; G = Green; B = Blue; P = Pink; O = Orange; Y = Yellow.

	viewAngles
	Viewing angles for 2D surface images [0:15:90]

	bwMatrix
	Binary image of fine-grained matrix threshold at mean grayscale

	bwParticles 
	Binary image of whole particles (excluding cropped grains)

	bwParticlesFull
	Binary image of whole particles (excluding cropped grains)

	ccParticlesFull
	Contains the following:
Connectivity: Connectivity used to identify touching particles (default = 6)
ImageSize: Size of the basket image
NumObjects: Number of particles
PixelIdxList: Lists of pixels in each particle

	dataParticles
	Contains the following arrays:
ParticleID = unique grain identifier from the 'labelParticleFull' array
Centroid = 3D coordinates of the grain centre of mass (uniform density)
VolumeMM3 = grain volume (mm3) found from image voxel resolution (in mm)
BoundingBox = grain bounding box used to find local mean bed elevation
CroppedFlag = logical (whole stone = 0, stone cropped off at bottom = 1)
MajorAxisMM = the major principal axis of the particle (mm)
MedianAxisMM = the median principal axis of the particle (mm)
MinorAxisMM = the minor principal axis of the particle (mm)
AxisVectors = 3x3 orthonormal matrix describing axes spatial orientation
MaxElevMM = the maximum elevation of the particle in the sample (mm)
MaxElevCoord = the 3D coordinates of MaxElevMM as voxel indices
MatrixContactAreaRatio = matrix fines contact area-to-total area ratio 
ExposureRatio = exposed-to-total 2D grain area ratio at each 'viewAngles'
ExposureFactor = calculated from each 'ExposureRatio' at each 'viewAngles'
FrontalAreaMM2 = grain cross-sectional area perpendicular to streamflow (mm)
OverheadAreaMM2 = grain cross-sectional area parellel to streamflow (mm)
FrontalImage = binary 2D projected image of grain viewed from upstream

	dataParticles.Contacts
	An Nx8 matrix called 'Contacts' is assigned as a metric to each object stone in 'dataParticles', where N is the number of neighbouring  particles in proximal contact with the object stone, and the columns are:
Column 1 is ParticleID of the contact stone to the current object stone
Column 2 is squared voxel distance between the object and contact stone
Columns 3-5 are the 3D coordinates of the proximal contact point
Columns 6-8 are the 3D coordiantes of the contact stone centroid

	dataParticles.Entrainment
	PivotAngle = angle within the POR between gravity and the AOR (degrees)
PlaneBearing = departure angle of POR from the downstream vector (degrees)
PlaneTilt = departure angle of POR from the gravity vector (degrees)
ProjectionMM = distance from mean local bed elevation to top of grain (mm)
TauCr = critical shear stress for grain entrainment (Pa)
TauCrStar = dimensionless critical shear stress (-)
DragForce = hydrodynamic fluid drag force (N)
LiftForce = hydrodynamic fluid lift force (N)
CohesiveForce = tensile resistance force due to fine-grain matrix (N)
SubmergedForce = submerged weight force of grain (N)
LeftRightPartIDs = left and right contact pairs forming rotation axis
Tests = proportions of four viable contact pair tests plus overall test
Params = a Matlab structure array of entrainment parameter settings

	labelParticles
	Same as 'labelParticlesFull' with cropped grains removed

	labelParticlesBed
	Labelled grains, but with replicated binary copies of the scanned sample image around the edge of the original sample image. This effectively extends the bed around the original sample image so that hiding effects of upstream stones may be realised. It is then converted to a label matrix where all stones in the extended bed are assigned a common ParticleID = n + 1 where n is the stone count in the sample. Since the outer edge of the sample tends to be rounded, a slight overlap of binary replicates are necessary to mimic natural bed surface continutity.

	labelParticlesFull
	Labelled grains used as ID (ordered top to bottom)

	labelParticlesSurf 
	Surface voxels for all grains in 'labelParticlesFull'

	stoneCheck
	Array for checking stone rotations


Table 3: Arrays and data contain in each Matlab .mat file
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Appendix:
Image reconstruction
Image reconstruction is a three-step process.  First, raw images from the scanner are sinograms that must be converted to radiographs.  Second, the centre of rotation (COR) of initially reconstructed volumes must be found.  Finally, information from the resulting file found from COR will be used during the algebraically reconstructed step to convert radiographs to reconstructed images.  The following are detailed steps for each of these three processes.
Converting sinograms to radiographs
1. In our case, we have a stack of sinograms for several samples in the “Sinograms” folder that resides at the same folder level as the HUTCH folder.  Sinograms for each sample basket must be put into separate folders named for the colour coding of each sample.  Make a folder called “DigiXCT” at the same level as HUTCH.  Within it make three subfolders called “Radio”, “Recon”, and “Sino” for radiograph, reconstruction and sinogram files, respectively.  
2. Each of these subfolders will contain folders that identify each sample scanned in the single HUTCH folder.  For example, three baskets with colour codes “1YY”, “2RB”, and “5PY” will be given these folder names to identify each sample from that one scanning job.  These named folders will reside in each of subfolder listed in Step 1.
3. Copy corresponding sinograms stacks for each sample from the Sinogram folder into their code named folders within the Sino parent folder.
4. Run the sinogram to radiograph converter located in the µ-Vis folder on the Windows Start menu.  Point the input path to each colour code folders within the Sino folder and point the output path to each corresponding folder within the Radio folder.  Then run the program.  The program will create a radiograph stack in each of the code-named folders. 
Centre of rotation, COR
1. Open Nikon CT Pro 2D.
2. Open the *.xtek2dct file that resides in the HUTCH folder.  In our case, this file contains images of samples that were placed into an acrylic tube and scanned.  These images have yet to be centred along their COR.
3. Click the “Centre of Rotation” tab.
a. Click “Change” button for the 1st index under “Reposition centre of rotation slices”.
b. Select the first stack and lower slice number where the image density is largest.
c. Close “Change” button and repeat for 2nd index using the lowest image in the tube.
4. Click the “Volume” tab and reduce the “Radius of Reconstruction” to between 70 & 80%.  This will remove any missed section of scans as each sample is not centred in scanning tube.
5. Click “Centre of Rotation” tab and depress the “Start” button to find centres at both indices.
6. Once both CORs are found, click the “Volume” tab.
a. Change “Radius of Reconstruction” back to 100%.
b. Make sure resolution is 100% and the volume is 512 x 512.
c. Change “Output Format” to Volume of Floats.
d. Set “Volume input conversion” to none.
7. Click the “Image” tab.
a. Click File > Save As to open the Save As GUI and remove everything after the experimental run number from the file name.
b. Add “_CC” to the filename for every completed basket image and “_CCincomplete” for incomplete scans, where CC = sample colour code.
c. Finish the filename by ending it in “_Recon” to show this image is now centred.
d. Save the file.
8. Right-click “CT Agent: Idle” on the Windows toolbar and chose “restore”.
9. Drag and drop all *_Recon.xtex2dct files onto the CT Agent for batch processing.
10. To check data, open the *.vgi file in the newly made folder to launch VG Studio Max.
Algebraic reconstruction
1. Open DigiXCT3 64 bit.
2. Open the *_Recon.xtek2dct file in Notepad to view flat file information.  
3. Open a single radiograph in Fiji (ImageJ) to get (x,y) dimensions.  You only need one image for all the scanned samples listed in the flat file under “StackName1”, “StackName2”, etc.
4. Open the “My_calculator.xlsx” Excel file to enter information into the yellow boxes.
a. Copy “CentreOfRotation1” from the flat file into the appropriate box in Excel.  Similarly with the “CentreOfRotation2”, “DetectorPixelSizeX”, “VoxelSizeX”, “SrcToObject”, and “SrcToDetector”.
b. Copy image size information (X, Y) from open image slice in Fiji (located at top left).
5. In DigiXCT3, select Tools > 3D Reconstruction Parameters…  There are 5 panels that need filling out for hardware, input, output, reconstruction, and preview/adjust.
a. Under “Hardware definition” there are two tabs.  In the “Camera definitions” tab…
i. Click the “+” button to open the “Create a new camera” dialog box.
ii. Name the camera “CLDA_Riverbed_RR_CC” where RR is the experimental run number and CC is the colour code for sample.  For convenience, name construction is included in the “My_calculator.xlsx” Excel file.
iii. Enter “Resolution [pix]” from Xdim and Ydim entries in My_calculator.xlsx.
iv. Enter “Pixel size” from DetectorPixelSizeX and VoxelSizeX entries in the red coloured cells, which are converted into micrometres.
v. Entries for “Camera size” will adjust automatically upon other entries.
vi. Click the “Create” button to accept values and close “Create a new camera”.
b. Now click the “Geometry definition” tab in the “Hardware definition” panel.
i. Enter “Axis [degrees]” under “Theta” from corresponding value in My_calculator.xlsx file under “Geometry Definitions” heading.
ii. Similarly enter “Center” under “X” from “Center X” Excel file value.
iii. Enter “Source Position” under “Z” from “Source Pos Z” Excel file value.
iv. Enter “Ref Point (Upper, Left)” under “X”, “Y”, and “Z” from the last three values for “Ref Point X”, “Ref Point Y*”, and “Ref Point Z”, respectively.
v. Change the “Source geometry” dropdown box to “Prism Y”.
vi. Note the 3D drawing in the “Perspective” window changes with each entry.
c. Under the “Input” panel, there are three tabs.  In the “Input definition” tab…
i. Click the ellipsis “…” button under “Image files” to open the “Select input image” dialog box.  Go to folder containing the sample radiograph stack.
ii. Depress Ctrl + A keys to select all radiograph files in the folder.  Click Open.
iii. Select the “Set white level” radio button and click the “Compute” button.
iv. The other two tabs for “Pre-processing” and “Image correction” are not used for this case study, but can be used if needed.
d. Under the “Output” panel, there is only one tab.
i. Select “0: Image stack” from the “Output format” dropdown box.
ii. Click on the ellipsis “…” button next to “Output file” to open the “Save the construction to an Image Stack” dialog box.  
iii. Then select “TIFF image” from the “Save as type:” dropdown box.
iv. Give the filename a short, simple name to identify experimental run and the sample colour code.  For example, for Run3 and code YY use “r3yy”.  This will result in a stack of files named “r3yy0000.tif”, “r3yy0001.tif”, etc.
v. Change the path to the correct subfolder under the “Recon” folder, and click the “Open” button to open the “Export images…” dialog box.  Choose the “32bps signed float” option from the “Data type:” dropdown box.  Leave the “Multi pages image:” checkbox unchecked.  Click the “OK” button to close the dialog box.  “Output file” now shows path with simple filename.
vi. Enter “Size” under the “Dimension” section the “Size X”, “Size Y”, and “Size Z” entries from the “Output Dimensions” section of the My_calculator.xlsx file.  Note this again changes the 3D drawing in the “Perspective” window by drawing a pink box where the sample is targeted in the scanner.
vii. Finally, enter the “Resolution (voxel)” values from the corresponding section in the My_calculator.xlsx file.
e. Under the “Reconstruction” tab, there are two tabs when the “Method” is FBP.
i. Select the “NITRO” option under the “Method” dropdown box, which reduced the number of tabs to one named “Method”.  You can choose whichever method works for you, but in our case, NITRO was best.
ii. If you check the “Expert user” checkbox at the bottom of this tab, you will be given another tab called “Volume processing”.  Use this if there is a need for filters or removing ring artefacts.  For our case, we need a grainy looking sand matrix, where we will later extract sub-voxel level information.
f. Under “Preview/Adjust” panel, there are two tabs.  Under “Preview settings” tab…
i. Select “1/8” option under the “Images for preview” dropdown box.
ii. Select “50.0%” option under the “Images resolution” dropdown box.
iii. Change the “Plane normal” unit vector entry to read (0, 1, 0).  Note these values will automatically update to unit vector quantities so keep changing until you get (0, 1, 0) values.
g. Under the “Parameter adjustments” in the “Preview/Adjust” panel…
i. Select “Center X” option from the “Parameter(s)” dropdown box.
ii. Check the “Autocontrast” checkbox.  Click the “Recompute” button.
iii. When computations are complete, you will be given a choice of three images to choose from.  Click the “Choose best image position” button that corresponds with the best image.  Use the mouse scroll wheel to zoom in and out of the images.  We want grainy looking sand matrix whilst still having sharp looking edges for larger stones.
iv. Click the “Recompute” button and repeat the process for however long is necessary until you are happy with the images to choose from.  When you’re done, click the “Accept geometry” button.
h. Finally, check the “Show Preview” checkbox underneath the five panels and click the “3D” button to calculate the sample preview in the “Perspective” drawing window.  This will insert a small rendering of the sample into the drawing.
i. Click the “Save as” button and give a filename that includes the experimental run number and the colour code sample name along with any settings.  So in our case, we named our file “DigiXCT_RR_CC_NITRO_NoPrePro_NoFilter.cal”  since we used NITRO reconstruction algorithm and did not use and filtering or pre-processing.  Again RR and CC are the run number and colour coding, respectively.
j. Finally, clicking on the “Save & Go” button opens up the “Start reconstruct…” dialog box.  Be sure all the settings are good to go before clicking on the “Proceed…” button to start reconstructions.  The reconstructed stack will be put into the appropriate subfolder of the “Recon” folder.
Registration and Clipping
Once reconstructions are complete, we will use VGStudio Max to reorient the reference frame such that the XY plane is orthogonal to the gravity vector, which is in the same direction as the Z-axis.  Recall that each sample basket had a downstream marker, and each basket was levelled such that gravity was normal to the top rim of the basket.  Use Fiji to find the downstream marker (cable tie) along the top rim of the metal basket (since it’s difficult to see in VGStudio).  Once the basket image is levelled, referred to as “registering the image”, we will clip the image of each basket at the third ring down from the top rim of the basket so that the analysis is the same for each image.
1. Open VGStudio Max.
2. Import stack from DigiXCT reconstruction (completed in the previous section).
a. File > Import > Image stack… to open Image Stack dialog box.
b. Click the “Add…” button in the “Filetype” section.
c. Navigate to the stack folder and then select all files in the folder using Ctrl + A keys. 
d. Click the “Open” button to populate the “File selection” window in the dialog box.
e. Click the “Next >” button.
f. In the “Load as” section of the dialog box, enter resolution in each (X, Y, Z) windows.  In our case, the resolution is 0.5999mm.
g. Click the “Next >” button to advance to the “ROI and Skip selection” screen.  
h. Make sure the index fully covers the image stack (note these start at slice 0).
i. Click the “Next >” button and then the “Finish” button.
3. The four panel view shows three 2D slice images in the XY-, XZ-, and YZ-planes (note reference frames in the lower left corner of each of these panels), and a 3D image in the lower right panel (note the orientation of the basket is nearly correct such that the Z-axis is near to pointing in the direction of gravity).  There is a toolbar on the bottom of the 3D viewer panel.  Expand the 3D view by clicking on the button that looks like a hollow black outlined box, which is located on the far right of the toolbar.  You can click again on the same button, which now looks like a bold underscore, to return to the four panel view.  Use the mouse to change the perspective of the 3D view so that you are looking down on the top of the sample basket.  You can zoom in and out of any point in the image by placing the mouse curser over that point and use the mouse scroll wheel whilst holding down the control key.  Now zoom in on the top rim of the wire basket so that you can also see several stones from the sample.
4. There are several panels to the right of the viewer panel: Scene Tree, Volume Rendering, etc.  In the Volume Rendering panel, use the mouse to grab the vertical red isosurface bar in the “Opacity manipulation area” and move it to the right.  This vertical bar provides a grayscale threshold from which voxels with grayscale values to the left of the bar are removed from view while those to the right of the vertical bar remain.  Observe medium density objects (like stones) will threshold out of view before high density object (like the basket) as the red bar is moved from left to right over the histogram of grayscales.  Since we will use the top rim of the sample basket to register the image, we must be careful to not erode the rim from view.  You only need to remove enough stone so that the top rim is visible at three equally spaced points around the rim.
5. Along the top toolbar there is a button that looks like a yellow die with red dots on each face.  Clicking this button to opens the “Simple 3-2-1 registration…” dialog box.  Now use the scroll wheel and control key to zoom into the top rim of the basket, and whilst holding down the control key, click on a high point on the basket rim.  This places a small yellow marker on any surface where the mouse is clicked.  Zoom out and into another high point on the rim that is roughly a third way around the basket rim to place a second yellow marker, and do the same for a third point.   Once the third point is placed a yellow grid should appear indicating the surface to be parallel to the XY-plane.   Zoom out and rotate the image around to view it from all side views to check that the yellow grid is contacting the basket rim (or nearly so).  Click the “Reset” button on the dialog box if you need to start over; otherwise click the “Finished” button to accept the values.
6. Now reduce the expanded viewer panel to its original view so you can see the three other 2D images.  Click on the top view 2D image panel (upper left panel), and use the scroll wheel to advance through image slices.  Observe that as you scroll through slices, a blue plane moves through the 3D image indicating the position of the image slice in all the 2D images.  You will know whether the image is properly registered when you see the entire rim of the basket within a single top-view slice.  If not, return to the expanded 3D view, click the yellow dice, and hit the “Reset” button to start over.
7. At this point in the process, you might notice that the black background of the top left view image has rotated after registering.  If the rotation is only slight, this is fine.  But if it has rotated anything beyond, say 15°, you should rotate it back to vertical.  To do so, click the dropdown arrow button next to the yellow dice to click on the “Simple registration…” button, which will open a small “Volume 1” dialog box and display what appears to be crosshairs over each 2D image panel.  Be extremely careful as moving any arrows in the side view 2D images will tilt the image out of registration and you’ll have to start over.  Carefully position the mouse over the top view image changes the mouse icon to indicate you can now rotate the image.  Do so to bring the black background of the image square within the viewing panel, and then click the “Finish” button on the dialog box to accept the new orientation.  Be sure to recheck that the image is still correctly registered by scrolling through top view slices.
8. Next we need to clip the image at the third ring down from the top rim of the basket such that the bottom of the image is coincident along the fourth ring.  These next few steps are a bit tricky, so read through the remainder of this section before you start.  Click the yellow box with dashed outline toward the top of the left toolbar.  This opens up a small “Select: Rectangle” toolbar.  In the side view 2D panel (lower left panel), draw a selection box around the image such that the bottom of the selection box runs through the fourth ring of the sample basket whilst enclosing the rest of the image of stones (FIGURE).  This is easier to do if you exclude a slight sliver of the black background outside the selection box at the top and both sides.  Note the red lines that are drawn in the other two 2D viewer panels.  These are a third dimension of the selection box, which is actually a selection cube.  Drag these red line boundaries of the selection cube to the sides of the black background in each 2D image to completely form a selection cube that encloses the entire sample except the bottom portion that will be excluded after clipping.  To check the selection cube is properly positioned, click each 2D panel and then start scrolling through image slices.  Note there are 2D planes that appear in the 3D image: a blue plane for the top view panel, a red plane for one of the side view panels, and a green plane for the other side view panel.  As soon as a panel appears, you can then use the mouse to grab the plane in the 3D viewer panel to move it back and forth through the 3D image.  Do so such that each plane runs through the centre of the 3D image.  Whilst doing so check that the basket is fully enclosed within the selection cube.   Right-click in any of the 2D panels to open the popup menu, and select the red “R” icon “New region of interest” from the menu.  This changes the colour of the selection cube and creates a new “Region 1” under a “Region of interest” in the “Scene Tree” panel to the right of all the image panels.  Right-click on the “Region of interest” in this tree, and choose “Extract ROI” from the popup menu.  This creates another view in the “Scene Tree” called “Region 1 of Volume 1”.  Clicking on the yellow lock next to each level in the “Scene Tree” locks/unlocks the images in the viewers.  Make sure they are all locked; otherwise changing the orientation in the 3D viewer panel affects views in the other 2D panels.  Unchecking the checkbox in the original “Volume 1” in the tree results in the clipped image being viewed in the four viewer panels.  Inspect the bottom of the 3D image to see that it is clipped properly.   Finally, select “Region 1 of Volume 1” in the tree, and then click File > Export >  Export aligned / multiple volumes… to open the “Aligned / multiple volume export” dialog box.  Leave the default values of “Scene coordinate system”, “Top”, “unsigned 16bit”, and the resolution of 0.5999 along all dimensions.  Note the grid sizes as you must include each of these in the filename of the raw image file to be exported.  Click the “Save…” button and export the volume as a “Raw volume (*.raw)” file type.  Give it a filename that includes information about the sample, current processing, and 3D grid size.  In our case, we give named files “<RR><CC>_Registered_Clipped_x<XXX>_y<YYY>_z<ZZZ>.raw”, where RR and CC are the experimental flume run and sample colour code, respectively, and XXX, YYY, ZZZ are the numerical values in the “Destination grid size” section of the “Aligned / multiple volume export” dialog box.  For example, “r1py_Registered_Clipped_x515_y509_z154.raw”.   When the “vgl file” dialog box opens asking you if you want to create a vgl file, click “Save” to save a VGL file under the same filename.  If you ever need to come back to make adjustments to the registered and clipped image, then go directly to this file to save time.  Close VGStudio and reopen to start registering and clipping another image.
9. Use Fiji (ImageJ) to rotate the downstream marker so that is points in down the X-axis.   WARNING: Do not run Fiji over a network desktop; it can be buggy.  Run on local drive only.
a.  Select File > Import > Raw… to open the “Open Raw…” dialog box.  Navigate to and open the raw file, which in turn opens the “Import…” dialog box.  
b. Select the “16-bit Unsigned” image type and enter XYZ values indicated in the filename as Width = X, Height = Y and Number of images = Z (HINT: the filename should be visible in the status line of the Fiji GUI).  Be sure “Little-endian byte order” is the only checked box, and click “OK” to open the image.
c. Examine the top view photo to find the black plastic downstream tab attached somewhere on the top rim of the sample basket.  Compare the photo with the top view of the image as you scroll through the upper layers.  The tab might show up as a medium grayscale lump on the outside of the upper rim of the basket.  You may need to select from any number of items under the Image > Transform submenu to transform the image to look like the photo so you can get it oriented correctly.  You can always correct the vertical orientation later when you export to the final 16bit grayscale stack that you will be importing into Matlab.
d. To rotate marker to downstream direction select Image > Transform > Rotate to open the “Rotate” dialog box.  Check the “Preview” checkbox to see how the image will look once it has rotated.  Use a “Bilinear” interpolation.  Enter values in the “Angle (degrees)” textbox until you get the marker to line up with the cross-hair on the right side of the image, which is the positive X-axis.  Click “OK” to finish, and be sure the image is a 16-bit unsigned image by selecting Image > Type > 16-bit.
e. Select File > Save As > TIFF… to open the “Save as TIFF” dialog box.  Save it in the “Recon” folder along with its original raw image; however, this time replace the XYZ grid size information in the filename with “_Rotated.tif”.  For example, save the file as “r1py_Registered_Clipped_Rotated.tif”.  The XYZ grid size is no longer needed as this information is automatically transferred when opening TIFF images.  Using this filename reminds you that the image has been registered, clipped and rotated.
f. Use Long16 for matrix contact and Short16 for particle analysis.


image1.emf

image2.png
(0,0)
Co-ordinates of central basket locations
Downstream/cross-stream dist (mm):
Riffle crest (RC): (4900, 690)
Pool head (PH): (7400, 720)
Pool deep (PD): (9980, 295)

Pool shallow (PS): (9980, 1015)
Q Pool tail (PT): (14350, 670)

(NBTLS data are in a different coordinate system)

Yy €

Flow





